Wednesday, August 28, 2013

Fixed arutcam video streaming on Android 4.2

In version 1.9 of arutcam video streaming has been fixed. I tested the app on Sony Xperia with Android 4.2.2 and it could not stream video, only audio. Now it's fixed, please update the application.

Many small bugs are fixed in arutcam as well.

15 comments:

  1. I can not stream video on Android 4.0.3. Only Audio. Version 1.9.
    Stat shows:
    and 2 2194454 1547140 70 70 0x0 0 H264 AAC publishing 3m 7s

    ReplyDelete
  2. I see "H264" in stats which means video is present as well but not shown for some reason. Please
    1. try playing with ffplay.
    2. disable audio and try video-only mode

    ReplyDelete
  3. 1. ffplay plays video.
    2. disabling audio does not help for playing video with flowplayer.

    Flowplayer can play another stream from ordinary webcam.

    ReplyDelete
  4. BTW if you record flv can you play it with flowplayer? If not please send it to me, I'll find the reason.

    ReplyDelete
  5. I've got another Mediatek device with MTK6577T chipset (slightly newer than yours) and it plays well.

    ReplyDelete
  6. I get "publish error: start failed" followed by "Publish error: unlock failed" - Xperia sola with Android 4.1.2.

    ReplyDelete
    Replies
    1. I think you get this after some other actions. What are they?

      Delete
  7. If I disable audio, all goes well. If the video is enabled and I press "Publish" the first messenger appears. When I press the button for the second time (albo third and more) the the second message appears.

    ReplyDelete
    Replies
    1. Select default frame-rate, that solved this problem for me.

      Delete
  8. The first sentence should be: "if I disable video".

    ReplyDelete
  9. Hi,
    I have ICS 4.0.4, i can't see Setting, so i can't input rtmp url.
    Help me. Thanks

    ReplyDelete
  10. Hello!

    I have tested application with Lenovo S750, Lenovo A1000, and Samsung N8000.
    On all devices I got error that "IO error: sendto failed: EPIPE (Broken pipe)".

    Is this error connected with application or with media server. I use Nginx with RTMP module.

    Thanks!

    ReplyDelete
    Replies
    1. It means the other side (nginx-rtmp) closed the connection for some reason while publishing.

      Delete